$re = '/<a.+?href=["\'](?!\.\.)([^"\']+)["\'].*?>(.+?)<\/a>/im';
$str = '<a href="..">..</a></td><a href="Example.pdf">Example.pdf</a>
<a href="www.example.com">Example.pdf</a>
<a href="http://www.example.com">Example.pdf</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);