using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(PT|PL|ES|EN)SVG(A|U)(001|801|992|994)";
string input = @"PLSVGA001
PLSVGA801
PLSVGA992
PLSVGA994
PLSVGU001
PLSVGU801
PLSVGU992
PLSVGU994
PLSVGU002
PLSVGU802
PTSVGA001
PTSVGA801
PTSVGA992
PTSVGA994
PTSVGU001
PTSVGU801
PTSVGU992
PTSVGU994
PTSVGU002
PTSVGU802
ESSVGA001
ESSVGA801
ESSVGA992
ESSVGA994
ESSVGU001
ESSVGU801
ESSVGU992
ESSVGU994
ESSVGU002
ESSVGU802
ENSVGA001
ENSVGA801
ENSVGA992
ENSVGA994
ENSVGU001
ENSVGU801
ENSVGU992
ENSVGU994
ENSVGU002
ENSVGU802
-----------
PTSVZC001
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}