use strict;
my $str = 'PLSVGA001
PLSVGA801
PLSVGA992
PLSVGA994
PLSVGU001
PLSVGU801
PLSVGU992
PLSVGU994
PLSVGU002
PLSVGU802
PTSVGA001
PTSVGA801
PTSVGA992
PTSVGA994
PTSVGU001
PTSVGU801
PTSVGU992
PTSVGU994
PTSVGU002
PTSVGU802
ESSVGA001
ESSVGA801
ESSVGA992
ESSVGA994
ESSVGU001
ESSVGU801
ESSVGU992
ESSVGU994
ESSVGU002
ESSVGU802
ENSVGA001
ENSVGA801
ENSVGA992
ENSVGA994
ENSVGU001
ENSVGU801
ENSVGU992
ENSVGU994
ENSVGU002
ENSVGU802
-----------
PTSVZC001
';
my $regex = qr/(PT|PL|ES|EN)SVG(A|U)(001|801|992|994)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}