import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(PT|PL|ES|EN)SVG(A|U)(001|801|992|994)";
final String string = "PLSVGA001\n"
+ "PLSVGA801\n"
+ "PLSVGA992\n"
+ "PLSVGA994\n"
+ "PLSVGU001\n"
+ "PLSVGU801\n"
+ "PLSVGU992\n"
+ "PLSVGU994\n"
+ "PLSVGU002\n"
+ "PLSVGU802\n"
+ "PTSVGA001\n"
+ "PTSVGA801\n"
+ "PTSVGA992\n"
+ "PTSVGA994\n"
+ "PTSVGU001\n"
+ "PTSVGU801\n"
+ "PTSVGU992\n"
+ "PTSVGU994\n"
+ "PTSVGU002\n"
+ "PTSVGU802\n"
+ "ESSVGA001\n"
+ "ESSVGA801\n"
+ "ESSVGA992\n"
+ "ESSVGA994\n"
+ "ESSVGU001\n"
+ "ESSVGU801\n"
+ "ESSVGU992\n"
+ "ESSVGU994\n"
+ "ESSVGU002\n"
+ "ESSVGU802\n"
+ "ENSVGA001\n"
+ "ENSVGA801\n"
+ "ENSVGA992\n"
+ "ENSVGA994\n"
+ "ENSVGU001\n"
+ "ENSVGU801\n"
+ "ENSVGU992\n"
+ "ENSVGU994\n"
+ "ENSVGU002\n"
+ "ENSVGU802\n"
+ "-----------\n"
+ "PTSVZC001\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}