// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(PT|PL|ES|EN)SVG(A|U)(001|801|992|994)").unwrap();
let string = "PLSVGA001
PLSVGA801
PLSVGA992
PLSVGA994
PLSVGU001
PLSVGU801
PLSVGU992
PLSVGU994
PLSVGU002
PLSVGU802
PTSVGA001
PTSVGA801
PTSVGA992
PTSVGA994
PTSVGU001
PTSVGU801
PTSVGU992
PTSVGU994
PTSVGU002
PTSVGU802
ESSVGA001
ESSVGA801
ESSVGA992
ESSVGA994
ESSVGU001
ESSVGU801
ESSVGU992
ESSVGU994
ESSVGU002
ESSVGU802
ENSVGA001
ENSVGA801
ENSVGA992
ENSVGA994
ENSVGU001
ENSVGU801
ENSVGU992
ENSVGU994
ENSVGU002
ENSVGU802
-----------
PTSVZC001
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}