#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!.*`.*|.*<code>.*)_(?!.*`.*|.*<\/code>.*)([^_]*)_(?!.*`.*|.*<\/code>.*)+(?![^\(]*\))+(?![^\[]*\])"
Local $sString = "* an *unordered* list" & @CRLF & _
" * with some **hierarchy**" & @CRLF & _
" 1. and an _ordered_" & @CRLF & _
" * list" & @CRLF & _
" * directly" & @CRLF & _
" * inside" & @CRLF & _
"some text _bla_ text testing _it_ out" & @CRLF & _
"some text `*bla*` `/**text*/` testing _it_ out" & @CRLF & _
"[Plastic bag code](https://en.wikivoyage.org/wiki/Common_scams#Plastic_bag_code)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")