$re = '/(?!.*`.*|.*<code>.*)_(?!.*`.*|.*<\/code>.*)([^_]*)_(?!.*`.*|.*<\/code>.*)+(?![^\(]*\))+(?![^\[]*\])/m';
$str = '* an *unordered* list
* with some **hierarchy**
1. and an _ordered_
* list
* directly
* inside
some text _bla_ text testing _it_ out
some text `*bla*` `/**text*/` testing _it_ out
[Plastic bag code](https://en.wikivoyage.org/wiki/Common_scams#Plastic_bag_code)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);