using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!.*`.*|.*<code>.*)_(?!.*`.*|.*<\/code>.*)([^_]*)_(?!.*`.*|.*<\/code>.*)+(?![^\(]*\))+(?![^\[]*\])";
string input = @"* an *unordered* list
* with some **hierarchy**
1. and an _ordered_
* list
* directly
* inside
some text _bla_ text testing _it_ out
some text `*bla*` `/**text*/` testing _it_ out
[Plastic bag code](https://en.wikivoyage.org/wiki/Common_scams#Plastic_bag_code)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}