import Foundation
let pattern = #"(?!.*`.*|.*<code>.*)_(?!.*`.*|.*<\/code>.*)([^_]*)_(?!.*`.*|.*<\/code>.*)+(?![^\(]*\))+(?![^\[]*\])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
* an *unordered* list
* with some **hierarchy**
1. and an _ordered_
* list
* directly
* inside
some text _bla_ text testing _it_ out
some text `*bla*` `/**text*/` testing _it_ out
[Plastic bag code](https://en.wikivoyage.org/wiki/Common_scams#Plastic_bag_code)
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)