package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?'first'.+\s)(\k'first')`)
var str = `שלום שלום רב לאוהבי תורתך ואין ואין למו מכשול`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}