import re
regex = re.compile(r"(?'first'.+\s)(\k'first')", flags=re.MULTILINE)
test_str = "שלום שלום רב לאוהבי תורתך ואין ואין למו מכשול"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)