#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d{4})(?:.* ((?:[1-9]|1[0-9]|2[0-4]) hour(?: 30 minutes)?))?"
Local $sString = "Pay for zone 1234 for 1 hour" & @CRLF & _
"Pay for zone 4567" & @CRLF & _
"Pay for zone 1234 for 13 hour 30 minutes" & @CRLF & _
"Pay for zone 1234 for 13 hour 30 minutes" & @CRLF & _
"Pay for zone 1234 for 24 hour 30 minutes" & @CRLF & _
"Pay for zone 1234 for 25 hour 30 minutes"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")