use strict;
my $str = 'Pay for zone 1234 for 1 hour
Pay for zone 4567
Pay for zone 1234 for 13 hour 30 minutes
Pay for zone 1234 for 13 hour 30 minutes
Pay for zone 1234 for 24 hour 30 minutes
Pay for zone 1234 for 25 hour 30 minutes';
my $regex = qr/(\d{4})(?:.* ((?:[1-9]|1[0-9]|2[0-4]) hour(?: 30 minutes)?))?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}