using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{4})(?:.* ((?:[1-9]|1[0-9]|2[0-4]) hour(?: 30 minutes)?))?";
string input = @"Pay for zone 1234 for 1 hour
Pay for zone 4567
Pay for zone 1234 for 13 hour 30 minutes
Pay for zone 1234 for 13 hour 30 minutes
Pay for zone 1234 for 24 hour 30 minutes
Pay for zone 1234 for 25 hour 30 minutes";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}