using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:https?:\/\/)?(?:m\.)?vk\.(com|ru).*(photo|video|audio|doc|page|note|poll|album|market|market_album|audio_playlist)(-?\d+)_(\d+)\/?$";
string input = @"https://vk.com/doc62315302_482044965
https://m.vk.com/doc62315302_482044965
http://vk.com/doc62315302_482044965
http://m.vk.com/doc62315302_482044965
vk.com/doc62315302_482044965
m.vk.com/doc62315302_482044965";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}