// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:https?:\/\/)?(?:m\.)?vk\.(com|ru).*(photo|video|audio|doc|page|note|poll|album|market|market_album|audio_playlist)(-?\d+)_(\d+)\/?$").unwrap();
let string = "https://vk.com/doc62315302_482044965
https://m.vk.com/doc62315302_482044965
http://vk.com/doc62315302_482044965
http://m.vk.com/doc62315302_482044965
vk.com/doc62315302_482044965
m.vk.com/doc62315302_482044965";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}