re = /^(?:https?:\/\/)?(?:m\.)?vk\.(com|ru).*(photo|video|audio|doc|page|note|poll|album|market|market_album|audio_playlist)(-?\d+)_(\d+)\/?$/m
str = 'https://vk.com/doc62315302_482044965
https://m.vk.com/doc62315302_482044965
http://vk.com/doc62315302_482044965
http://m.vk.com/doc62315302_482044965
vk.com/doc62315302_482044965
m.vk.com/doc62315302_482044965'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end