import re
regex = re.compile(r"^(?:https?:\/\/)?(?:m\.)?vk\.(com|ru).*(photo|video|audio|doc|page|note|poll|album|market|market_album|audio_playlist)(-?\d+)_(\d+)\/?$", flags=re.MULTILINE)
test_str = ("https://vk.com/doc62315302_482044965\n"
"https://m.vk.com/doc62315302_482044965\n"
"http://vk.com/doc62315302_482044965\n"
"http://m.vk.com/doc62315302_482044965\n"
"vk.com/doc62315302_482044965\n"
"m.vk.com/doc62315302_482044965")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")