#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+\s+[-]\s+.*?(?=\s+-)|\d+\s+[-].*)"
Local $sString = "Opcao 01 - Frase123 aleatória - Menu Superior" & @CRLF & _
"Opcao 02 - Outra123 Frase aleatória - Menu Su" & @CRLF & _
"Opcao 03 - Mais123 01 Frase - Menu" & @CRLF & _
"Opcao 04 - Mais123 Frase -" & @CRLF & _
"Opcao 05 - Frase123 Simples"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")