use strict;
my $str = 'Opcao 01 - Frase123 aleatória - Menu Superior
Opcao 02 - Outra123 Frase aleatória - Menu Su
Opcao 03 - Mais123 01 Frase - Menu
Opcao 04 - Mais123 Frase -
Opcao 05 - Frase123 Simples';
my $regex = qr/(\d+\s+[-]\s+.*?(?=\s+-)|\d+\s+[-].*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}