using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+\s+[-]\s+.*?(?=\s+-)|\d+\s+[-].*)";
string input = @"Opcao 01 - Frase123 aleatória - Menu Superior
Opcao 02 - Outra123 Frase aleatória - Menu Su
Opcao 03 - Mais123 01 Frase - Menu
Opcao 04 - Mais123 Frase -
Opcao 05 - Frase123 Simples";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}