$re = '/\/((?:(?: ?)\w+)*)/';
$str = 'COMMAND 2000 _Tree_Item_Selection java.lang.String /application files/Test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);