re = /\/((?:(?: ?)\w+)*)/
str = 'COMMAND 2000 _Tree_Item_Selection java.lang.String /application files/Test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end