using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d)(?=\d*:)(?=.{8}(.))((?=(1|.(?=.{8}1))*?1.{8}1\d*~.(1))|(?=.*?~(0)))(?=.*?~.*?\1\2(\5|\6)_(.))|:.*";
string substitution = @"$8";
string input = @"01101100:01010100~01000_0001_1010_1100_1011_0110_0101_0111_1";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}