const regex = /(\d)(?=\d*:)(?=.{8}(.))((?=(1|.(?=.{8}1))*?1.{8}1\d*~.(1))|(?=.*?~(0)))(?=.*?~.*?\1\2(\5|\6)_(.))|:.*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d)(?=\\d*:)(?=.{8}(.))((?=(1|.(?=.{8}1))*?1.{8}1\\d*~.(1))|(?=.*?~(0)))(?=.*?~.*?\\1\\2(\\5|\\6)_(.))|:.*', 'g')
const str = `01101100:01010100~01000_0001_1010_1100_1011_0110_0101_0111_1`;
const subst = `$8`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);