$re = '/(\d)(?=\d*:)(?=.{8}(.))((?=(1|.(?=.{8}1))*?1.{8}1\d*~.(1))|(?=.*?~(0)))(?=.*?~.*?\1\2(\5|\6)_(.))|:.*/';
$str = '01101100:01010100~01000_0001_1010_1100_1011_0110_0101_0111_1';
$subst = "$8";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;