import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d)(?=\\d*:)(?=.{8}(.))((?=(1|.(?=.{8}1))*?1.{8}1\\d*~.(1))|(?=.*?~(0)))(?=.*?~.*?\\1\\2(\\5|\\6)_(.))|:.*";
final String string = "01101100:01010100~01000_0001_1010_1100_1011_0110_0101_0111_1";
final String subst = "$8";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}