# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/{(\w+)}\s*(\((\d+)[),])?/{\"name\":\"$1\", \"count\":\"$3\"}/g;t' <<< "{item1}, {item2} (2), {item3} (4), {item4}
(1), {item5}, {item6}(5)"