package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{(\w+)}\s*(\((\d+)[),])?`)
var str = `{item1}, {item2} (2), {item3} (4), {item4}
(1), {item5}, {item6}(5)`
var substitution = "{\"name\":\"$1\", \"count\":\"$3\"}"
fmt.Println(re.ReplaceAllString(str, substitution))
}