import Foundation
let pattern = #"{(\w+)}\s*(\((\d+)[),])?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{item1}, {item2} (2), {item3} (4), {item4}
(1), {item5}, {item6}(5)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"{\"name\":\"$1\", \"count\":\"$3\"}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)