# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"{(\w+)}\s*(\((\d+)[),])?"
test_str = ("{item1}, {item2} (2), {item3} (4), {item4}\n"
" (1), {item5}, {item6}(5)")
subst = "{\\\"name\\\":\\\"$1\\\", \\\"count\\\":\\\"$3\\\"}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.