# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\|\|(?!\([^\)]+\))//gm;t' <<< "abc | efg || $something(\"arg 1\", \"arg 2||(a|b)\") || 123"