const regex = /\|\|(?!\([^\)]+\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\|\\|(?!\\([^\\)]+\\))', 'gm')
const str = `abc | efg || \$something("arg 1", "arg 2||(a|b)") || 123`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);