re = /\|\|(?!\([^\)]+\))/m
str = 'abc | efg || $something("arg 1", "arg 2||(a|b)") || 123'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result