use strict;
my $str = 'abc | efg || $something("arg 1", "arg 2||(a|b)") || 123';
my $regex = qr/\|\|(?!\([^\)]+\))/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";