import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^http:\\/\\/example\\.com\\/api.*";
final String string = "http://example.com/api\n"
+ "http://example.com/api/auth (should match)\n"
+ "http://example.com/api/orders (should match)\n"
+ "http://example.com/api/products (should match)\n"
+ "http://example.com/auth (should not match)\n"
+ "http://examples.com/api/auth (should not match)\n"
+ "https://example.com/api/auth (should not match)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}