import re
regex = re.compile(r"^http:\/\/example\.com\/api.*", flags=re.MULTILINE)
test_str = ("http://example.com/api\n"
"http://example.com/api/auth (should match)\n"
"http://example.com/api/orders (should match)\n"
"http://example.com/api/products (should match)\n"
"http://example.com/auth (should not match)\n"
"http://examples.com/api/auth (should not match)\n"
"https://example.com/api/auth (should not match)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")