// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^http:\/\/example\.com\/api.*").unwrap();
let string = "http://example.com/api
http://example.com/api/auth (should match)
http://example.com/api/orders (should match)
http://example.com/api/products (should match)
http://example.com/auth (should not match)
http://examples.com/api/auth (should not match)
https://example.com/api/auth (should not match)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}