re = /^http:\/\/example\.com\/api.*/m
str = 'http://example.com/api
http://example.com/api/auth (should match)
http://example.com/api/orders (should match)
http://example.com/api/products (should match)
http://example.com/auth (should not match)
http://examples.com/api/auth (should not match)
https://example.com/api/auth (should not match)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end