const regex = new RegExp('[^0-9.]+', 'gm')
const str = `есть значения к примеру 42.5 или 39.5 нужно оставить только цифры и точку`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);