import re
regex = re.compile(r"[^0-9.]+", flags=re.MULTILINE)
test_str = "есть значения к примеру 42.5 или 39.5 нужно оставить только цифры и точку"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)