use strict;
my $str = 'есть значения к примеру 42.5 или 39.5 нужно оставить только цифры и точку';
my $regex = qr~[^0-9.]+~mp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";