$re = '~[^0-9.]+~m';
$str = 'есть значения к примеру 42.5 или 39.5 нужно оставить только цифры и точку';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;