#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\h*USE(?!\h*\[{0,2}[^]\s]*(?:\$|(?i:master)))\h*\[{0,2}[^]\s]*]{0,2}"
Local $sString = "USE [master]" & @CRLF & _
"USE [Master]" & @CRLF & _
" - don't match" & @CRLF & _
"" & @CRLF & _
"USE [$(CompiledDatabaseName)]" & @CRLF & _
" - don't match" & @CRLF & _
"" & @CRLF & _
"USE [anything_else.01234]" & @CRLF & _
" - match" & @CRLF & _
"USE [[somestring]]" & @CRLF & _
"use [anything_else.01234]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")