import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\h*USE(?!\\h*\\[{0,2}[^]\\s]*(?:\\$|(?i:master)))\\h*\\[{0,2}[^]\\s]*]{0,2}";
final String string = "USE [master]\n"
+ "USE [Master]\n"
+ " - don't match\n\n"
+ "USE [$(CompiledDatabaseName)]\n"
+ " - don't match\n\n"
+ "USE [anything_else.01234]\n"
+ " - match\n"
+ "USE [[somestring]]\n"
+ "use [anything_else.01234]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}