$re = '/^\h*USE(?!\h*\[{0,2}[^]\s]*(?:\$|(?i:master)))\h*\[{0,2}[^]\s]*]{0,2}/m';
$str = 'USE [master]
USE [Master]
- don\'t match
USE [$(CompiledDatabaseName)]
- don\'t match
USE [anything_else.01234]
- match
USE [[somestring]]
use [anything_else.01234]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);