const regex = /^\h*USE(?!\h*\[{0,2}[^]\s]*(?:\$|(?i:master)))\h*\[{0,2}[^]\s]*]{0,2}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\h*USE(?!\\h*\\[{0,2}[^]\\s]*(?:\\$|(?i:master)))\\h*\\[{0,2}[^]\\s]*]{0,2}', 'gm')
const str = `USE [master]
USE [Master]
- don't match
USE [\$(CompiledDatabaseName)]
- don't match
USE [anything_else.01234]
- match
USE [[somestring]]
use [anything_else.01234]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}