#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<AC>\d{3})(?<First>\d{3})(?<Last>\d{4})\s(?<EXT>(E?X?T?e?x?t?\.?\s?\d{1,7})?)"
Local $sString = "5133521652 extension 1234" & @CRLF & _
"5133521652 Extension 1234" & @CRLF & _
"5133521652 extension 1234" & @CRLF & _
"5133521652 e 1234" & @CRLF & _
"5133521652 x 1234" & @CRLF & _
"5133521652 t 1234" & @CRLF & _
"5133521652 ex 1234" & @CRLF & _
"5133521652 ext 1234" & @CRLF & _
"5133521652 E 1234" & @CRLF & _
"5133521652 X 1234" & @CRLF & _
"5133521652 T 1234" & @CRLF & _
"5133521652 e. 1234" & @CRLF & _
"5133521652 X 1234" & @CRLF & _
"5133521652 Ext 1234" & @CRLF & _
"5133521652 EXT 1234" & @CRLF & _
"5133521652 EXT. 1234" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")