import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<AC>\\d{3})(?<First>\\d{3})(?<Last>\\d{4})\\s(?<EXT>(E?X?T?e?x?t?\\.?\\s?\\d{1,7})?)";
final String string = "5133521652 extension 1234\n"
+ "5133521652 Extension 1234\n"
+ "5133521652 extension 1234\n"
+ "5133521652 e 1234\n"
+ "5133521652 x 1234\n"
+ "5133521652 t 1234\n"
+ "5133521652 ex 1234\n"
+ "5133521652 ext 1234\n"
+ "5133521652 E 1234\n"
+ "5133521652 X 1234\n"
+ "5133521652 T 1234\n"
+ "5133521652 e. 1234\n"
+ "5133521652 X 1234\n"
+ "5133521652 Ext 1234\n"
+ "5133521652 EXT 1234\n"
+ "5133521652 EXT. 1234\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}