use strict;
my $str = '5133521652 extension 1234
5133521652 Extension 1234
5133521652 extension 1234
5133521652 e 1234
5133521652 x 1234
5133521652 t 1234
5133521652 ex 1234
5133521652 ext 1234
5133521652 E 1234
5133521652 X 1234
5133521652 T 1234
5133521652 e. 1234
5133521652 X 1234
5133521652 Ext 1234
5133521652 EXT 1234
5133521652 EXT. 1234
';
my $regex = qr/^(?<AC>\d{3})(?<First>\d{3})(?<Last>\d{4})\s(?<EXT>(E?X?T?e?x?t?\.?\s?\d{1,7})?)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}